US SMS Carrier Maintenance - Small US Carriers
Maintenance
in progress
7 hours 32 minutes
April 02, 12:00am
US SMS Carrier Maintenance - Small US Carriers
Status: in progress
Start:
April 02, 12:00am
Estimated Duration: 360 minutes
Affected Components:
3rd Party Providers
Twilio
SMS Long Code, North America
SMS Short Code, North America
SMS Toll-Free, North America
Update
April 02, 12:00am
April 02, 12:00am
A subset of small networks in the US are conducting a planned maintenance from 01 April 2026 at 21:00 PDT until 02 April 2026 at 03:00 PDT. During the maintenance window, there could be intermittent delays delivering SMS to small US carriers handsets.
Copyright (C) 2024.