On Call Engineers are Investigating

Informational
March 31, 11:27am

On Call Engineers are Investigating

Status: closed
Date: March 30, 6:56pm
End: March 31, 11:27am
Duration: 16 hours 30 minutes
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America MMS Long Code, North America SMS Short Code, North America MMS Short Code, North America SMS Toll-Free, North America MMS Toll-Free Text-to-Speech TwiML
Investigating

March 30, 6:56pm

March 30, 6:56pm

Our monitoring systems have detected a potential issue with SMS Delivery Failures. Our engineers have been alerted and are investigating. We will provide an update when we have more details.

Investigating

March 30, 7:25pm

March 30, 7:25pm

Twilio customers may be experiencing SMS delivery failures from a subset of Twilio Phone Numbers to multiple networks in multiple countries, including Egypt, Trinidad and Tobago, Suriname, and Somalia. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Investigating

March 30, 8:26pm

March 30, 8:26pm

We are continuing to experience SMS delivery failures from a subset of Twilio Phone Numbers to multiple networks in multiple countries, including Egypt, Trinidad and Tobago, Suriname, and Somalia. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.

Investigating

March 30, 10:16pm

March 30, 10:16pm

We are continuing to experience SMS delivery failures from a subset of Twilio Phone Numbers to multiple networks in multiple countries, including Egypt, Trinidad and Tobago, Suriname, and Somalia. Our team is actively investigating this issue. We will provide another update in 4 hours or as soon as more information becomes available.

Investigating

March 31, 2:34am

March 31, 2:34am

We are continuing to experience SMS delivery failures from a subset of Twilio Phone Numbers to multiple networks in multiple countries, including Egypt, Trinidad and Tobago, Suriname, and Somalia. Our team is actively investigating this issue. We will provide another update in 8 hours or as soon as more information becomes available.

Monitoring

March 31, 8:40am

March 31, 8:40am

We are observing successful SMS delivery from a subset of Twilio Phone Numbers to multiple networks in multiple countries, including Egypt, Trinidad and Tobago, Suriname, and Somalia. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.

Monitoring

March 31, 10:38am

March 31, 10:38am

We are observing successful SMS delivery from a subset of Twilio Phone Numbers to multiple networks in multiple countries, including Egypt, Trinidad and Tobago, Suriname, and Somalia. We will continue to monitor to ensure full service recovery. We expect to provide another update in 4 hours or as soon as more information becomes available.

Resolved

March 31, 11:27am

March 31, 11:27am

The incident has been resolved and SMS delivery from a subset of Twilio Phone Numbers to multiple networks in multiple countries, including Egypt, Trinidad and Tobago, Suriname, and Somalia is operating normally.