SMS Delivery Delays From a Subset of Twilio Short Codes and Long Codes to United States

Incident
April 21, 3:31pm

SMS Delivery Delays From a Subset of Twilio Short Codes and Long Codes to United States

Status: closed
Start: April 21, 6:46am
End: April 21, 3:31pm
Duration: 8 hours 44 minutes
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America SMS Short Code, North America
Investigating

April 21, 6:46am

April 21, 6:46am

Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes and Long Codes to the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Investigating

April 21, 7:47am

April 21, 7:47am

Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes and Long Codes to the United States. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.

Investigating

April 21, 9:45am

April 21, 9:45am

Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes and Long Codes to the United States. Our team is actively investigating this issue. We will provide another update in 4 hours or as soon as more information becomes available.

Investigating

April 21, 9:48am

April 21, 9:48am

Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes and Long Codes to the United States. Our team is actively investigating this issue. We will provide another update in 4 hours or as soon as more information becomes available.

Identified

April 21, 11:28am

April 21, 11:28am

Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes and Long Codes to the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

April 21, 12:29pm

April 21, 12:29pm

Twilio customers may be experiencing SMS delivery delays from a subset of Twilio Short Codes and Long Codes to the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.

Monitoring

April 21, 1:30pm

April 21, 1:30pm

We have observed a recovery in SMS delivery from a subset of Twilio Short Codes and Long Codes to the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.

Monitoring

April 21, 1:30pm

April 21, 1:30pm

We have observed a recovery in SMS delivery from a subset of Twilio Short Codes and Long Codes to the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.

Resolved

April 21, 3:31pm

April 21, 3:31pm

The incident has been resolved and SMS delivery from a subset of Twilio Short Codes and Long Codes to the United States is operating normally.