United States SMS Carrier Partner Maintenance
Maintenance
in progress
12 hours 40 minutes
May 07, 12:00am
United States SMS Carrier Partner Maintenance
Status: in progress
Start:
May 07, 12:00am
Estimated Duration: 480 minutes
Affected Components:
3rd Party Providers
Twilio
SMS Short Code, North America
Update
May 07, 12:00am
May 07, 12:00am
Our SMS carrier partner in the United States is conducting a planned maintenance from 06 May 2026 at 21:00 PDT until 07 May 2026 at 05:00 PDT. During the maintenance window, there could be intermittent delays delivering SMS to United States handsets via United States short codes.
Copyright (C) 2024.