SMS and MMS Delivery Delays from Twilio Phone Numbers to Verizon United States

Incident
May 29, 1:54am

SMS and MMS Delivery Delays from Twilio Phone Numbers to Verizon United States

Status: closed
Start: May 27, 1:13pm
End: May 29, 1:54am
Duration: 1 day 12 hours 40 minutes
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America MMS Long Code, North America SMS Short Code, North America MMS Short Code, North America SMS Toll-Free, North America MMS Toll-Free
Investigating

May 27, 1:13pm

May 27, 1:13pm

Twilio customers may be experiencing SMS and MMS delivery delays from Twilio Phone Numbers to Verizon network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Investigating

May 27, 2:14pm

May 27, 2:14pm

Twilio customers may be experiencing SMS and MMS delivery delays from Twilio to Verizon network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.

Identified

May 27, 2:18pm

May 27, 2:18pm

Twilio customers may be experiencing SMS and MMS delivery delays from Twilio to Verizon network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

May 27, 3:19pm

May 27, 3:19pm

Twilio customers may be experiencing SMS and MMS delivery delays from Twilio to Verizon network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.

Identified

May 27, 5:30pm

May 27, 5:30pm

Twilio customers may be experiencing SMS and MMS delivery delays from Twilio to Verizon network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.

Identified

May 27, 9:45pm

May 27, 9:45pm

We have observed a recovery in SMS delivery however, customers may still experience MMS delivery delays when sending from Twilio phone numbers to Verizon subscribers in the United States. Our engineering team has identified the root cause and is actively working on a resolution. We will provide another update in 8 hours, or sooner if new information becomes available.

Identified

May 28, 4:37am

May 28, 4:37am

We have observed a recovery in SMS delivery however, customers may still experience MMS delivery delays when sending from Twilio phone numbers to Verizon subscribers in the United States. Our engineering team has identified the root cause and is actively working on a resolution. We will provide another update in 8 hours, or sooner if new information becomes available.

Identified

May 28, 5:47am

May 28, 5:47am

We have observed a recovery in SMS delivery however, customers may still experience MMS delivery delays when sending from Twilio phone numbers to Verizon subscribers in the United States. Our engineering team has identified the root cause and is actively working on a resolution. We will provide another update in 8 hours, or sooner if new information becomes available.

Identified

May 28, 4:56pm

May 28, 4:56pm

We are continuing to work on a fix for this issue.

Monitoring

May 28, 7:34pm

May 28, 7:34pm

We have observed a recovery in SMS and MMS delivery from Twilio to Verizon network subscribers in the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.

Monitoring

May 28, 9:49pm

May 28, 9:49pm

We have observed a recovery in SMS and MMS delivery from Twilio Phone Numbers to Verizon network subscribers in the United States and are monitoring service stability. We will provide another update in 4 hours or as soon as more information becomes available.

Resolved

May 29, 1:54am

May 29, 1:54am

The incident has been resolved and SMS and MMS delivery from Twilio to Verizon network subscribers in the United States are operating normally.