SMS Delivery Delays and Failures from Multiple Networks to a Subset of Twilio United States Phone Numbers

Incident
May 29, 3:13am

SMS Delivery Delays and Failures from Multiple Networks to a Subset of Twilio United States Phone Numbers

Status: closed
Start: May 29, 2:18am
End: May 29, 3:13am
Duration: 54 minutes
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America SMS Short Code, North America SMS Toll-Free, North America
Investigating

May 29, 2:18am

May 29, 2:18am

Twilio customers may be experiencing SMS delivery delays and failures from network subscribers to a subset of Twilio United States Phone Numbers. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

May 29, 3:09am

May 29, 3:09am

Twilio customers may be experiencing SMS delivery delays and failures from network subscribers in the United States to a subset of Twilio Phone Numbers. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Monitoring

May 29, 3:10am

May 29, 3:10am

We have observed a recovery in SMS delivery from network subscribers to a subset of Twilio United States Phone Numbers and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.

Resolved

May 29, 3:13am

May 29, 3:13am

The incident has been resolved and SMS delivery from the United States to a subset of Twilio Phone Numbers is operating normally.