MMS Delivery Delays from a Subset of Twilio Short Codes to Verizon United States

Incident
June 02, 6:33pm

MMS Delivery Delays from a Subset of Twilio Short Codes to Verizon United States

Status: closed
Start: June 02, 3:23pm
End: June 02, 6:33pm
Duration: 3 hours 9 minutes
Affected Components:
3rd Party Providers Twilio MMS Short Code, North America
Investigating

June 02, 3:23pm

June 02, 3:23pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Short Codes to Verizon network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

June 02, 3:28pm

June 02, 3:28pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Short Codes to Verizon network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

June 02, 3:42pm

June 02, 3:42pm

We are continuing to work on a fix for this issue.

Identified

June 02, 3:44pm

June 02, 3:44pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Short Codes to Verizon and T-mobile networks subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Monitoring

June 02, 4:31pm

June 02, 4:31pm

We have observed a recovery in MMS delivery from a subset of Twilio Short Codes to Verizon and T-Mobile network subscribers in the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.

Resolved

June 02, 6:33pm

June 02, 6:33pm

The incident has been resolved and MMS delivery from a subset of Twilio Short Codes to Verizon and T-Mobile network subscribers in the United States is operating normally.