SMS Delivery Failures from Twilio to Multiple Countries

Incident
June 06, 10:07pm

SMS Delivery Failures from Twilio to Multiple Countries

Status: in progress
Start: June 06, 6:33pm
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America SMS Short Code, North America SMS Toll-Free, North America
Investigating

June 06, 6:33pm

June 06, 6:33pm

Twilio customers may be experiencing SMS delivery failures from Twilio to multiple countries. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

June 06, 7:06pm

June 06, 7:06pm

Twilio customers may be experiencing SMS delivery failures from Twilio to multiple countries. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

June 06, 8:06pm

June 06, 8:06pm

Twilio customers may be experiencing SMS delivery failures from Twilio to multiple countries. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.

Identified

June 06, 10:07pm

June 06, 10:07pm

Twilio customers may be experiencing SMS delivery failures from Twilio to multiple countries. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.