Retroactive Incident: Mail Delivery Delay to a Small Subset of Users

Informational
June 11, 1:05pm

Retroactive Incident: Mail Delivery Delay to a Small Subset of Users

Status: closed
Date: June 11, 1:04pm
End: June 11, 1:05pm
Duration: 1 minute
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America MMS Long Code, North America SMS Short Code, North America MMS Short Code, North America SMS Toll-Free, North America MMS Toll-Free Text-to-Speech TwiML
Update

June 11, 1:04pm

June 11, 1:04pm

Twilio-Sengrid mail delivery was degraded for approximately 9 minutes between 9:18 AM and 9:27AM Pacific Time on 06/11/2026. During this period of time customers may have experienced delays affecting a subset of users. User experience was degraded with delayed mail delivery during this window, though the scope was limited to affected users rather than system-wide outage. The issue has now been resolved.

Resolved

June 11, 1:05pm

June 11, 1:05pm

Incident closed.