Twilio Sender ID Registrations Affected

Informational
June 12, 1:31pm

Twilio Sender ID Registrations Affected

Status: closed
Date: June 12, 1:30pm
End: June 12, 1:31pm
Duration: 1 minute
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America MMS Long Code, North America SMS Short Code, North America MMS Short Code, North America SMS Toll-Free, North America MMS Toll-Free Text-to-Speech TwiML
Update

June 12, 1:30pm

June 12, 1:30pm

Twilio Sender ID registrations was degraded for about 30 minutes between 9:24PM and 9:55PM Pacific Time on 06/11/2026. During this period of time customers may have experienced problems submitting Embedded Registrations. The issue has now been resolved.

Resolved

June 12, 1:31pm

June 12, 1:31pm

Incident closed.