Elevated Contentstore Latency Errors Affecting Message Delivery

Informational
June 15, 5:09pm

Elevated Contentstore Latency Errors Affecting Message Delivery

Status: closed
Date: June 15, 5:08pm
End: June 15, 5:09pm
Duration: 1 minute
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America MMS Long Code, North America SMS Short Code, North America MMS Short Code, North America SMS Toll-Free, North America MMS Toll-Free Text-to-Speech TwiML
Update

June 15, 5:08pm

June 15, 5:08pm

Twilio Contentstore was degraded for 13 minutes between 16:00 and 16:13 Pacific Time on 06/02/2026. During this period of time customers may have experienced latency in message delivery and processing capabilities. The issue has now been resolved.

Resolved

June 15, 5:09pm

June 15, 5:09pm

Incident closed.