SMS Delivery Failures from Twilio to Multiple Networks in Multiple Countries

Incident
July 07, 5:03pm

SMS Delivery Failures from Twilio to Multiple Networks in Multiple Countries

Status: closed
Start: July 07, 11:09am
End: July 07, 5:03pm
Duration: 5 hours 53 minutes
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America SMS Short Code, North America SMS Toll-Free, North America
Investigating

July 07, 11:09am

July 07, 11:09am

Twilio customers may be experiencing SMS delivery failures from Twilio to multiple networks in multiple countries. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

July 07, 11:47am

July 07, 11:47am

Twilio customers may be experiencing SMS delivery failures from Twilio to network subscribers on multiple networks in multiple countries across APAC and Middle East & Africa. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

July 07, 12:34pm

July 07, 12:34pm

Twilio customers may be experiencing SMS delivery failures from Twilio to Entel network subscribers in Bolivia and Softbank network subscribers in Japan. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

July 07, 1:38pm

July 07, 1:38pm

Twilio customers may be experiencing SMS delivery failures from Twilio to Entel network subscribers in Bolivia and Softbank network subscribers in Japan. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.

Monitoring

July 07, 3:03pm

July 07, 3:03pm

We have observed a recovery in SMS delivery from Twilio to Entel network subscribers in Bolivia, Softbank network subscribers in Japan, and MTN network subscribers in Ghana and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.

Resolved

July 07, 5:03pm

July 07, 5:03pm

The incident has been resolved and SMS delivery from Twilio to Entel network subscribers in Bolivia, Softbank network subscribers in Japan and MTN network subscribers in Ghana is operating normally.