MMS Delivery Delays From Network Subscribers to a Subset of Twilio United States Short Codes

Incident
July 08, 8:16pm

MMS Delivery Delays From Network Subscribers to a Subset of Twilio United States Short Codes

Status: closed
Start: July 08, 3:55pm
End: July 08, 8:16pm
Duration: 4 hours 20 minutes
Affected Components:
3rd Party Providers Twilio MMS Short Code, North America
Investigating

July 08, 3:55pm

July 08, 3:55pm

Twilio customers may be experiencing MMS delivery delays from network subscribers to a subset of Twilio United States Short Codes. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

July 08, 5:00pm

July 08, 5:00pm

Twilio customers may be experiencing MMS delivery delays from network subscribers to a subset of Twilio United States Short Codes. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.

Monitoring

July 08, 6:02pm

July 08, 6:02pm

We have observed a recovery in MMS delivery from network subscribers on multiple networks in the United States to a subset of Twilio Short Codes and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.

Monitoring

July 08, 6:14pm

July 08, 6:14pm

We have observed a recovery in MMS delivery from network subscribers on multiple networks in the United States to a subset of Twilio Short Codes and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.

Monitoring

July 08, 8:15pm

July 08, 8:15pm

We have observed a recovery in MMS delivery from network subscribers on multiple networks in the United States to a subset of Twilio Short Codes and are monitoring service stability. We will provide another update in 4 hours or as soon as more information becomes available.

Resolved

July 08, 8:16pm

July 08, 8:16pm

The incident has been resolved and MMS delivery from network subscribers on affected networks in the United States to a subset of Twilio Short Codes is operating normally.