SMS and MMS Delivery Delays from Twilio to T-Mobile United States

Incident
July 13, 5:22pm

SMS and MMS Delivery Delays from Twilio to T-Mobile United States

Status: closed
Start: July 13, 11:37am
End: July 13, 5:22pm
Duration: 5 hours 44 minutes
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America MMS Long Code, North America SMS Short Code, North America MMS Short Code, North America SMS Toll-Free, North America MMS Toll-Free
Investigating

July 13, 11:37am

July 13, 11:37am

Twilio customers may be experiencing SMS and MMS delivery delays from Twilio to T-Mobile network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

July 13, 12:40pm

July 13, 12:40pm

Twilio customers may be experiencing SMS and MMS delivery delays from Twilio to T-Mobile network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.

Identified

July 13, 2:51pm

July 13, 2:51pm

Twilio customers may be experiencing SMS and MMS delivery delays from Twilio to T-Mobile network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Monitoring

July 13, 3:19pm

July 13, 3:19pm

We have observed a recovery in SMS and MMS delivery from Twilio to T-Mobile network subscribers in the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.

Resolved

July 13, 5:22pm

July 13, 5:22pm

The incident has been resolved and SMS and MMS delivery from Twilio to T-Mobile network subscribers in the United States are operating normally.