On Call Engineers are Investigating Loss of Audit Event Data for Twiml Applications From July/15 to July/21 - 2026

Informational
July 21, 9:22pm

On Call Engineers are Investigating Loss of Audit Event Data for Twiml Applications From July/15 to July/21 - 2026

Status: closed
Date: July 21, 7:14pm
End: July 21, 9:22pm
Duration: 2 hours 7 minutes
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America MMS Long Code, North America SMS Short Code, North America MMS Short Code, North America SMS Toll-Free, North America MMS Toll-Free Text-to-Speech TwiML
Investigating

July 21, 7:14pm

July 21, 7:14pm

Our monitoring systems have detected a potential issue with loss of audit event data for Twiml Applications From July/15 to July/21 - 2026. Our engineers have been alerted and are investigating. We will provide an update when we have more details.

Identified

July 21, 7:44pm

July 21, 7:44pm

Our engineers have identified the issue about some customers using TwiML applications that have experienced complete loss of audit event data spanning from July 15 through July 21, 2026.. We expect to provide another update in 1 hour or as soon as more information becomes available.

Monitoring

July 21, 9:00pm

July 21, 9:00pm

TwiML applications that have experienced complete loss of audit event data spanning from July 15 through July 21, 2026 are now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.

Resolved

July 21, 9:22pm

July 21, 9:22pm

TwiML applications that have experienced complete loss of audit event data spanning from July 15 through July 21, 2026 are now operating normally. This incident has been resolved.