Unable to save Phone Numbers with Studio Flow

Informational
July 24, 9:30am

Unable to save Phone Numbers with Studio Flow

Status: closed
Date: July 24, 4:52am
End: July 24, 9:30am
Duration: 4 hours 37 minutes
Affected Components:
3rd Party Providers Twilio SMS Long Code, North America MMS Long Code, North America SMS Short Code, North America MMS Short Code, North America SMS Toll-Free, North America MMS Toll-Free Text-to-Speech TwiML
Investigating

July 24, 4:52am

July 24, 4:52am

Our monitoring systems have detected a potential issue with saving phone numbers in studio flow. Our engineers have been alerted and are investigating. We will provide an update when we have more details.

Investigating

July 24, 5:13am

July 24, 5:13am

Our engineers are investigating the issue causing generic errors when saving phone number configurations assigned to a Studio Flow in the Console, and are actively working to deploy a fix. As a temporary workaround, please ensure a valid Status Callback URL is populated when setting your Voice URL to a Studio Flow. We expect to provide another update in 1 hour or as soon as more information becomes available

Investigating

July 24, 5:52am

July 24, 5:52am

Our engineers continue to investigate the issue causing generic errors when saving phone number configurations assigned to a Studio Flow in the Console, and are actively working to deploy a fix. As a temporary workaround, please ensure a valid Status Callback URL is populated when setting your Voice URL to a Studio Flow. We expect to provide another update in 2 hour or as soon as more information becomes available

Monitoring

July 24, 7:39am

July 24, 7:39am

The issue causing generic errors when saving phone number configurations assigned to a Studio Flow in the Console are now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.

Resolved

July 24, 9:30am

July 24, 9:30am

We are no longer experiencing generic errors when saving phone number configurations assigned to a Studio Flow in the Console. This incident has been resolved.