MMS Delivery Delays from a Subset of Twilio Short Codes to Verizon and T-Mobile United States

Incident
July 28, 4:28am

MMS Delivery Delays from a Subset of Twilio Short Codes to Verizon and T-Mobile United States

Status: closed
Start: July 28, 1:28am
End: July 28, 4:28am
Duration: 2 hours 59 minutes
Affected Components:
3rd Party Providers Twilio MMS Short Code, North America
Investigating

July 28, 1:28am

July 28, 1:28am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Short Codes to Verizon and T-Mobile network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Monitoring

July 28, 2:26am

July 28, 2:26am

We have observed a recovery in MMS delivery from a subset of Twilio Short Codes to Verizon and T-Mobile network subscribers in the United States and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.

Resolved

July 28, 4:28am

July 28, 4:28am

The incident has been resolved and MMS delivery from a subset of Twilio Short Codes to Verizon Wireless and T-Mobile network subscribers in the United States is operating normally.