MMS Delivery Delays from a Subset of Twilio Short Codes to T-Mobile United States

Incident
August 13, 2:39pm

MMS Delivery Delays from a Subset of Twilio Short Codes to T-Mobile United States

Status: in progress
Start: August 13, 9:19am
Affected Components:
3rd Party Providers Twilio MMS Short Code, North America
Investigating

August 13, 9:19am

August 13, 9:19am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Short Codes to T-Mobile network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

August 13, 9:43am

August 13, 9:43am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Short Codes to T-Mobile network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

August 13, 10:51am

August 13, 10:51am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Short Codes to T-Mobile network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.

Identified

August 13, 11:33am

August 13, 11:33am

Twilio customers may be experiencing MMS delivery receipt delays from a subset of Twilio Short Codes to T-Mobile network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

August 13, 12:33pm

August 13, 12:33pm

Twilio customers may be experiencing MMS delivery receipt delays from a subset of Twilio Short Codes to T-Mobile network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 2 hours or as soon as more information becomes available.

Identified

August 13, 2:39pm

August 13, 2:39pm

Twilio customers may be experiencing MMS delivery receipt delays from a subset of Twilio Short Codes to T-Mobile network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. Message delivery may succeed, but delivery receipts may be delayed. We will provide another update in 4 hours or as soon as more information becomes available.