MMS Delivery Delays from a Subset of Twilio Long Codes to C-Spire United States

Incident
September 02, 7:48pm

MMS Delivery Delays from a Subset of Twilio Long Codes to C-Spire United States

Status: closed
Start: August 26, 10:48am
End: September 02, 7:48pm
Duration: 7 days 8 hours 59 minutes
Affected Components:
3rd Party Providers Twilio MMS Long Code, North America
Investigating

August 26, 10:48am

August 26, 10:48am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Investigating

August 26, 11:50am

August 26, 11:50am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.

Identified

August 26, 12:21pm

August 26, 12:21pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.

Identified

August 26, 1:21pm

August 26, 1:21pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.

Identified

August 26, 3:30pm

August 26, 3:30pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.

Identified

August 26, 7:31pm

August 26, 7:31pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.

Identified

August 27, 3:31am

August 27, 3:31am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.

Identified

August 27, 7:32pm

August 27, 7:32pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.

Identified

August 28, 7:38pm

August 28, 7:38pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.

Identified

August 29, 7:42pm

August 29, 7:42pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.

Identified

August 30, 7:48pm

August 30, 7:48pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.

Identified

August 31, 7:48pm

August 31, 7:48pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.

Identified

September 01, 7:48pm

September 01, 7:48pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to C-Spire network subscribers in the United States. Our team has identified the cause, and is working to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.

Resolved

September 02, 7:48pm

September 02, 7:48pm

auto-closed