MMS Delivery Delays from a Subset of Twilio Long Codes to GCI United States

Incident
September 27, 6:31am

MMS Delivery Delays from a Subset of Twilio Long Codes to GCI United States

Status: in progress
Start: September 25, 11:16pm
Affected Components:
3rd Party Providers Twilio MMS Long Code, North America
Investigating

September 25, 11:16pm

September 25, 11:16pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to GCI network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.

Investigating

September 26, 12:17am

September 26, 12:17am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to GCI network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.

Investigating

September 26, 2:20am

September 26, 2:20am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to GCI network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 4 hours or as soon as more information becomes available.

Investigating

September 26, 6:24am

September 26, 6:24am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to GCI network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 8 hours or as soon as more information becomes available.

Investigating

September 26, 2:25pm

September 26, 2:25pm

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to GCI network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 16 hours or as soon as more information becomes available.

Investigating

September 27, 6:31am

September 27, 6:31am

Twilio customers may be experiencing MMS delivery delays from a subset of Twilio Long Codes to GCI network subscribers in the United States. Our team is actively investigating this issue. We will provide another update in 24 hours or as soon as more information becomes available.